MainWP Sucuri Extension

Download Link:

This is a support topic for MainWP Sucuri Extension

The intention of this topic is to give you the opportunity to discuss problems and difficulties with other Festinger Vault customers, e.g. how to address incompatibilities or fix bugs, report malfunctioning features, or get help on how to configure this download.

:warning: You can ask us for update requests here as well! :love_you_gesture:

To request an update of a particular theme or plugin, kindly let us know your preferred version number and we will update it as soon as possible. Although update requests usually do not make much sense because we publish them as soon as they are available and we have the time to upload them.

MainWP Sucuri Extension has been updated to 4.0.12


I wanted to install Sucuri (from MainWP) security plugin to replace Wordfence, but in order for the Sucuri plugin to work I was required to install additional plugins, such as MainWP dashboard, MainWP Child, and MainWP Extension plugins (yes, all of these 4 plugins need to be installed on each site that I want the Sucuri security plugin to work on, and I don’t know why but I’m not questioning anything with how complicated Wordpress has become lately)

So anyway, after installing and activating all of those 4 plugins on one of my sites I noticed that the MainWP Dashboard plugin still can’t detect the MainWP Extension plugin as being installed, which - obviously - is bad because without this plugin being detected as installed I can’t make use of the security plugin from Sucuri. So, what can be done to fix this? I’m assuming it’s a license conflict between the plugins in your vault and the MainWP site that provided you with the license, that’d be my guess but I’m not sure, I’m just speculating here. But if that’s the case then you are the only one who can fix this for me, which is why I am contacting you about this issue :slight_smile:

Here are 2 screenshots that will illustrate my issue:

Hey @rayden1980 – thanks a lot for your screenshots and I can understand your frustration in regards to this.

@FestingerUpdates – can you see if there is an update available for this source? As it looks like an incompatibility of the MainWP Sucuri Extension. If there is no future update available, I will submit a support ticket to the creators of this item to see if this can be fixed.

Sorry , No update is available for this extension.

I love your fast replies, dude. Keep up the good work :ok_hand:

I submitted a support ticket for you, let’s see if they can solve this issue.

Well, I’ll be here, waiting… Because if the can’t solve this… I have no other option for security plugins and that would suck :slight_smile:


Do you have any news about my issue with the Sucuri Extension?

Hey man,

I just replaced it with a new version. Can you see if that’s working?

If not, I am very sorry to say that we need more time to investigate this…

I can try the new version, but before that I need to say something, which is…

I think something could be wrong with your Vault because when I type “sucuri” into the search box - and I think that I mentioned this in a previous discussion - your system returns 2 plugins but they seem to have their names switched, because have a look at the 2 screenshots below:

I remember that when I first installed these 2 plugins Wordpress told me that I need the MainWP Dashboard plugin in order for the Sucuri extension to function, and I contacted you about this issue because I couldn’t find the MainWP dashboard plugin in your Vault and you told me that you’re not keeping free plugins, and so I went ahead and downloaded the free MainWP Dashboard plugin from the WP repository, installed it, and then, thinking that I didn’t need the MainWP Sucuri plugin anymore I un-installed it. So, probably that this is the plugin that the MainWP system can’t find, which I can re-install, no problem. But I think you should still switch the names of the 2 plugins in your Vault because I have a feeling that they are indeed switched, and this is probably where my issues stem from.

So, before I re-install the MainWP Sucury plugin (which, in reality, should probably be called MainWP Sucuri Extension 4.0.12), can you at least check whether or not the names of these 2 plugins are indeed switched, or whether the issue is truly somewhere else? If the 2 plugins are not switched with themselves, then tell me and I will un-install, and re-install everything. But like I said, I have a feeling that this is where the problem is…


I apologize for reviving this topic but I wasn’t able to find an answer otherwise…

I installed the Sucuri plugin (well, I clicked on the install button for the “MainWP Sucuri” plugin, as it appears in your vault), but your system also installed the “MainWP Sucuri Extension 4.0.12” plugin.

So, I installed one plugin but your system installed two of them instead, but the thing is that when I checked my list of installed plugins I can only see the “MainWP Sucuri Extension 4.0.12” plugin. Furthermore, the plugins page says that in order to use this plugin I should install the MainWP Dashboard plugin, but I can’t find this plugin in your vault. There are 47 Sucuri-related plugins in your vault, but none of them is named “MainWP Dashboard”, although I did see one of them that had the word “dashboard” in its title, but it didn’t look like what I needed, so I chose not to install it yet.

Here are 3 screenshots to help you understand what my situation is:

Screenshot 1 shows the message that tells me to install MainWP Dashboard…
Screenshot 2 shows that I only have the MainWP Sucuri Extension 4.0.12 plugin installed despite of the fact that I actually installed the MainWP Sucuri plugin instead…
Screenshot 3 shows that I have both those plugins installed, but - as you can see from screenshot 2 - only one of them is actually installed…

So, my question is: which plugins do I actually need to replace the Wordfence plugin (which I uninstalled 2 days ago because they blacklisted you, so without getting updated I have no reason to use Wordfence anymore… and I didn’t like WF anyway if I’m being honest)? So, which Sucuri plugins do I (still) need to install to replace Wordfence?

Hey @rayden1980 – thanks a lot for your comment here.

The MainWP Dashboard plugin can be downloaded from here:

We don’t list the files from on our website as they are free =)

I hope this answers your question.

oh yeah, it makes sense…

Good luck man!


Thanks for bringing this to my attention, I went ahead and removed the older version of this plugin as it was indeed a duplicated plugin.

Now, the version 4.0.12 is the right one and this should solve the issue.

Hey, man!

After nearly half a day of playing with all of the plugins and extensions from MainWP I think I am finally getting the hang of this thing… and I understood a few things that I need to clarify and that I can also recommend to you / ask of you. So, here it goes…

  1. first of all, the Sucuri extension issues that I’ve been having for the last week is finally solved, ALTHOUGH… it was solved way before I even contacted you about it because - as you will see from the 2 screenshots below - the Sucuri extension had been working the entire time. It’s just that I was mislead into believing that it doesn’t work for reasons that you can see in the 2 screenshots below, as I said.

Actually, let me post the 2 screenshots right now so you can see what I mean:

As you can see in both those screenshots I have circled in red the things that confused me and made me think that there is a problem with the Sucuri extensions (with all of them), because - in screenshot 1 - the “license” word is prepended with a red X, which made me think that I need to do something (which I had no idea about by the way) in order for that red X to turn into a green checkmark like the one that prepends the “Privacy” word (right to the left of the “License” word).

And screenshot 2 reinforced the idea in my mind that none of these extensions work because - as you can see in this 2nd screenshot - all of the extensions come with a “Deactivated” status, and with an exclamation mark to the right side of that status.

I saw both of those things (the red X near the “License” word in the 1st screenshot and the “Deactivated” and exclamation mark in the 2nd screenshot) and I thought all along that none of these extensions is being detected or even works, which is why I contacted you about it. But I actually went to the Extensions section of the MainWP dashboard and gave these extensions a test-run and they all bloody work for f*cks sake! Just how blinded or stupid can someone (ME) be? I would have saved both of us headaches and wasted time had I thought about actually checking whether the extensions work. So, I apologize for any trouble or distress that I might have caused you with my ignorance.

This being said, it’s still good that you removed that redundant Sucuri plugin from the vault because it wasn’t doing anything at all. It was just misleading and confusing people… well, it was confusing me, I don’t know about other people :slight_smile:

And speaking of confusing… this brings me to question #1, which is… is there a way for you to make the MainWP Dashboard plugin to detect the extensions as Active instead of Deactivated, and to replace the orange exclamation marks with green checkmarks as it should normally be? If that’s out of your control, no problem, I can live with the misleading statuses of these extensions, but I thought I should ask anyway :slight_smile:

And since I’m still on the “misleading and confusing” topic, here’s something else that I noticed…

You have the same extension (MainWP BackWPup) that’s uploaded 3 times in your vault, and I checked each one of those 3 instances and they are all the exact same thing, just under different names and URLs, which may or may not be bad. But since there’s no point in keeping the same extension under 3 different names and URLs (which might actually cause future conflicts, just like it happened with the Sucuri extension that you removed earlier today), I think you should remove the 2 older instances of this extension and only keep the newest version of it.

The extension that I’m talking about has all these 3 versions:

MainWP BackWPup Extension 4.0.5 -
MainWP BackWPup -
MainWP BackWPup 4.0.2 -

Like I said, I personally and manually went ahead and checked each one of these 3 variants and they’re all the same extension but under 3 different names. The latest version (and the one which you should keep in my opinion) is the 1st one in the list above, so I recommend that you remove the other 2, just to save yourself and your members future headaches and even conflicts between plugins. Just my honest recommendation, but of course that it’s your business, so you can do as you wish. I only said what I noticed :slight_smile:

  1. Last but not least, I noticed 2 more extensions from MainWP that I would be interested in installing on my sites, but which currently don’t exist in the vault:

MainWP Matomo - Matomo (formerly Piwik) for MainWP WordPress Management
MainWP Page Speed - Page Speed Plugin for MainWP WordPress Management

Do you think we can get these 2 extensions?? I mean, I would love to have them, but if thats not possible no problem. Asking never hurts, right? :slight_smile:

And that’s it… I think… It took me over 6 hours to go through everything that’s related to MainWP and Sucuri and figure out where the problem is and how this whole MainWP thing works (which I kind of started liking if I’m being honest), so I’m going offline and have my well-deserved rest because my head is buzzing lol…

Replying to your answer later… or maybe tomorrow, I will see when I recover :slight_smile:

Hey, @rayden1980 → first of all, thanks a lot for your comprehensive feedback, it’s really appreciated.

I can understand that this is misleading, but unfortunately, we do not have control over the free MainWP dashboard plugin as it will generally check through API to see if the plugin is activated/purchased.

This has been corrected as well → the correct one can be downloaded using the link below.

Actually, the Matomo plugin is the new name of this one:

Can you see if that’s still working with Matoma?

And I just purchased the MainWP Page Speed extension for you :wink:

Let me know if this helps!

it’s OK, I’m not bothered by that anymore. It was more a curiosity than a necessity, that’s why I asked…

I don’t think that it does, according to this screenshot:

But keep it there for a little while because I intend to contact the guys at MainWP to see if they have any plans of making it work, and I’ll update this post when I get an answer.

dang, you move fast! Thanks for adding it :slight_smile: